Can't load keys into client wallet


I’ve just downloaded and synced my client wallet. I’m now trying to load my keys into the Client wallet but I’m getting the following error message. “You cannot pair two keys with the same file name”. Can someone help please?

How can I load my keys? Thank you!

My system has the following specifications:

  • Client Wallet (and version)
  • Operating System and version: Windows 10
  • block # of your client: 2621157
  • of connections: 16


Have you tried renaming your keys? If not, try renaming them to: key1.private and key2.private and let us know if that works.


Thanks for your reply. The keys are already named key1.private and key2.private
Should I try naming them something else?


Are you certain you didn’t accidentally load the same key twice? If each one is a different name then make sure you are able to read the files with a basic text editor and that nothing looks out of the ordinary. If the problem persists let me know.


I don’t think I’ve uploaded any keys. How can I check or how can I start again?

I can read my keys with a text editor but I don’t know what out of the ordinary would look like. What should I be seeing?


you can activate debug in settings, and then restart the software, reproduce the bug and shut the software down and send me debug.txt

Although I really don’t understand why you would have an issue to begin with, you are simply opening your account and loading key1.private and key2.private right?

Worst case scenario you can email me your keys and I will try to reproduce the bug. But first try to activate the debugger and send me the results.


When I go debug I get this screen. What should I input here? Thanks


No thats the live debugger, I was saying to activate the debugger in settings, shut down the software, restart it, reproduce the bug by loading the keys, then close the software and send me the debug.txt it generates. And also you should try copying your keys to a different directory (perhaps c:\BitBay) and open them from there and make sure the names of each key is not the same. (key1.private and key2.private)
Also, were the keys previously used on a Mac computer? Or have you always used Windows 10?


Thanks for the clarification :slight_smile: I’m afraid that I don’t see how to activate the debugger in settings. Could you tell me how please? Thanks


It’s right there, says “Create Debug File on Exit”… then follow the instructions I gave you


I’m now having the issue that the wallet is stuck at 99% (stopped at synchronizing: 2623866). I’ve tried hitting rescan but it doesn’t make any difference. Any suggestions for what I should do? Thank you


You would have to resync (not rescan). Try to sync again using the bootstrap. Did you get your keys to load?


I only see rescan. I synced last time with the bootstrap but not sure how to sync again using the bootstrap unless you mean start all over again. Is that what you mean?

Still couldn’t get keys to loads.

Wanted to create the Debug File on Exit but I assume there’s no point until I can get the wallet 100% synced? Am I going about this in the correct order?

Thanks! :slight_smile:


Anyone there who can help please?


Hey @dzimbeck any thoughts on this?


Yeah resync by deleting files and using bootstrap again. And yes I asked for the debug on exit because I wanted to see why you can’t load your keys. Also please send me screenshots of you trying to load key1 and key2. Go to file/open wallet/…etc and take multiple screenshots of whats going on when you try to do it. Also what are the paths of the files on your computer?


@dzimbeck thanks for your instructions. I’m now installing again for the 4th time and really want to make sure don’t so something wrong.

Instructions say “To use the bootstrap, first remove all files in the data folder (except wallet.dat, peers.dat, and any testnet files)”. I see a bunch of files and folders in the ‘bitbaydata’ folder including wallet.dat but I don’t see peers.dat or anything with the word testnet in the file name.

Should I therefore delete everything apart from wallet.dat and add the bootstrap file, then open the wallet and let it sync?

Would really appreciate getting this sorted soon. Thanks again!


p.s. this is the folder


Yeah testnet is not used for Halo. And yes, just put bootstrap file in data directory, delete the rest except wallet.dat. As for the key locations I was curious if that was causing the problem, sometimes certain characters in the path name cause an error in some operating systems. That’s why I wanted to know exactly what the path was on both keys when you loaded them (key1 and key2)


OK, I’ve done everything exactly as instructed @dzimbeck . Started from scratch with bootstrap, at 100%, loaded in my keys. Seems to work but the client crashed. Had to restart my computer and use task manager to exit. Eventually managed to restart the client and it shows 0 balance.

How can I check if my keys have loaded properly? Or what can I do to solve this? Please help! Thank you